Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: Problem with instability  (Read 2082 times)

Cade_Foster

  • New Member
  • *
  • Posts: 8
    • View Profile
Problem with instability
« on: February 19, 2017, 08:36:18 am »

Hello everybody,

I have tried to carry out a simulation of a 100MW fire in a tunnel, unsuccessfully.

I have found two types of errors by pyrosim:

- First error: numerical instability.
- Second error that says "12.6 MB loaded in 0.11 s - rate: 918.2 Mb/s (overhead 0.01 s). Initializing 3D smoke/hrrpuv blanking array - complete".
- Third error that says "forrt1 severe (157): Program Exception - access violation".

My case is a 700m long tunnel, with a 100MW fire in a train car (in the outside surface). In order to overcome all those errors, I have tried these measures:

- Modify the mesh. I have modified the cells' size, from 0,5x0,5x0,25 to 0,5x0,5x0,5m (x, y, z).
- Before, I had 5 meshes in my pyrosim model. Now, I have unified all of them in a single mesh.
- I have increased the length of the tunnel that I am studying, in order to increase the distance between the fire vent and the entry and exit of the tunnel (having open, exhaust or supply vents close to a fire can create instability).

After all, all my efforts have been in vain, since I haven't been able to make my simulation converge.

I don't know what else to try. Does anyone have any idea that may help me?

I attach two images of the errors that I've found.

Thank you in advance. Cheers.
Logged

Jared

  • Member
  • **
  • Posts: 47
    • View Profile
Re: Problem with instability
« Reply #1 on: February 19, 2017, 11:06:34 am »

100MW is a huge fire and the geometry which you described is also very big.  Without seeing the code it is tough to determine what may be causing numerical instability.  When numerical instability happens it will automatically create a plot3d output on the last timestep that FDS performed.  If you load this plot3d file in smokeview, it may help show where the actual issue is taking place (sudden increase in value at a specific point).  If that is no help, slowly start to remove features from your model until you can run without numerical instability.  Then add the different features back in without the one that caused the issue.  This is a time extensive fix however.

What is your ramp time of your fire?  Do you have forced ventilation?  How large are your meshes?
Logged

Cade_Foster

  • New Member
  • *
  • Posts: 8
    • View Profile
Re: Problem with instability
« Reply #2 on: February 19, 2017, 01:38:14 pm »

Hello Jared,

Thank you for your response. According to the FDS User's Guide (section 16.7 Plot3D Static Data Dumps), the plot3d file has a .q extension.

I have tried to visualise the last file with .q extension, unsuccessfully. Which is the file that you are talking about?

Besides, there is a file with a .out extension that outlines the development of the simulation, that I attach to this message. I have seen that there is a huge increase in the maximum velocity error in the last time step before the calculation collapsing, as you will see.

Can I extract useful information from this file?

The fire growth is: t=0 (0 MW), t=5min (60 MW), t=12 min (100 MW), maintaining 100 MW during 1 hour. I also have a supply vent in one of the tunnel's entries.

Thank you for your aid, cheers.
Logged