Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: How to update FDS, which is used by Pyrosim?  (Read 3211 times)

bobby

  • New Member
  • *
  • Posts: 2
    • View Profile
How to update FDS, which is used by Pyrosim?
« on: April 24, 2010, 08:36:44 am »

Hello!
Pyrosim 2010 uses fds installed in itself (in Pyrosim folder). Now it is 5.4.1 version, but 5.5.1 version is avaible now on fds site! Tell me please how can I update fds which is used by Pyrosim?

Thank you!
Oleg.
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: How to update FDS, which is used by Pyrosim?
« Reply #1 on: April 26, 2010, 07:51:13 am »

By default, PyroSim uses a copy of FDS that is in the PyroSim/fds or PyroSim/fds64 folder.  You can change the FDS location using the Preferences dialog.  To change which version of FDS PyroSim uses:

1. Download and install your favorite version of FDS.
2. In PyroSim, on the File menu, click Preferences.
3. Under FDS Execution, click the folder icon next to the FDS 5 location box.
4. In the Open dialog, select your new FDS executable.
5. Repeat steps 3 and 4 for the remaining 3 location boxes.
6. Click OK

If you are using PyroSim''''s "Run Parallel" option with MPI, the MPI FDS 5 Location box must point to a version of fds5_mpi that matches PyroSim in terms of 32-bit vs 64-bit.  Otherwise parallel simulations will not run.
Logged

bobby

  • New Member
  • *
  • Posts: 2
    • View Profile
Re: How to update FDS, which is used by Pyrosim?
« Reply #2 on: April 27, 2010, 06:01:12 am »

Thank you very much!
It was so simple :)
Logged