Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: EVAC : disable mesh  (Read 6656 times)

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
EVAC : disable mesh
« on: February 04, 2010, 02:47:20 pm »

Hi,
I'm dealing with Evacuation simulation.
In order to test the set-up before proceeding with the complete simulation it is very useful to enable and disable the fire meshes and evacuation meshes.
In "common" fds code this can easily be done by deleting the ampersand ("&") from the unwanted mesh line.
In Pyrosim that's usually correspond to "disable" the selected object. It usually works but that function has no effect on the meshes (it can be seen from the source code).
Do I have to change some settings or that option doesn't work on Pyrosim?
Thanks for the help
Michele
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: EVAC : disable mesh
« Reply #1 on: February 05, 2010, 09:06:40 am »

I just did a quick test with PyroSim 2010.1.0928 (32-bit) and I wasn't able to reproduce the bug.  My disabled meshes do not appear in the record view or the FDS input file.

What am I missing?  Do you want them to appear in the input file without the ampersand?

Logged

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Re: EVAC : disable mesh
« Reply #2 on: February 05, 2010, 11:01:30 am »

Well, I also did some tests and seemed that the mesh is disabled when there are no line codes that recall the mesh. Attached is my FDS file.
Moreove I'm trying to test a simulation with both a fire and evacuation but I only get a "severe" error message. I'm trying everything to solve the problem.
From FDS discussion it seems to be a bug. I also tried to modify the fds file (not through Pyrosim) but did not get the point...
Thanks for the help on those topics.
Michele
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: EVAC : disable mesh
« Reply #3 on: February 05, 2010, 11:26:53 am »

Ah, it's a dependency thing.  Under the hood, when you disable an object PyroSim removes it from the list of stuff that will be written to the input file.  However, for any item that is written out (e.g. a VENT), PyroSim goes back and identifies anything that used by that item (e.g. MESH_ID).  Anything that's needed by the records from the first list are added to the input file as well - even, it would seem, if it had been previously disabled.  This system was designed to avoid writing out the entire material library and to support the copy/paste system.

In this case, your obstruction and your outflow vent both use EVAC mesh, so it still gets written even if disabled.  Similar for FIRE mesh.

We should just never write disabled items and add a couple dialogs (at disable time, at file write time) to notify you if this is going on (i.e. Outflow vent references disabled mesh, you're simulation will crash.)

Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: EVAC : disable mesh
« Reply #4 on: February 05, 2010, 11:34:06 am »

In your simulation, you should be getting:

forrtl: severe (61): format/variable-type mismatch, unit -5, file Internal Formatted Write

This is because your exit is a box, rather than a quad.  Changing "Min Y" to 0.3 moves us up to the following:

forrtl: severe (157): Program Exception - access violation

I haven't work out exactly what's responsible yet.  I suspect it has to do with setting the wrong combination of flow fields and meshes for the EXIT and EVAC records.  I also tried removing MESH_ID from your fire geometry and that didn't help.
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: EVAC : disable mesh
« Reply #5 on: February 08, 2010, 09:26:05 am »

Follow-up at the FDS forum where Timo explains the access violation and workaround:

http://groups.google.com/group/fds-smv/browse_thread/thread/3833c2a732807a8e

Short version: Evac meshes need to be smaller than fire meshes (usually in Z).
Logged

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Re: EVAC : disable mesh
« Reply #6 on: February 18, 2010, 04:17:54 am »

Charlie,
after a couple of week I'm coming back to the topic of disabling meshes.
The disabled mesh will still be considered in case of the presence of events (VENTs, OBSTs, ...) that recall it
Therefore once the complete fire+evacuation simulation is set up, the only way to test the fire and evacuation separately is to manually delete the ampersand "&" from the fds file and run it manually from the cmd-line, right?
Michele
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: EVAC : disable mesh
« Reply #7 on: February 18, 2010, 08:56:23 am »

That would kinda work, but I think you might still have problems with all the records that reference the mesh after you took it out of the input file.

If I were doing it, I'd probably:

1. Disable FDS+EVAC (this will disable PERS, EVHO, etc)
2. Disable the evac MESH
3. Disable your outflow vent and any other OBST, VENT, or HOLEs that explicitly reference your evac MESH.   You'll know when you've got them all because the evac MESH will be removed from the record view.

Logged

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Re: EVAC : disable mesh
« Reply #8 on: February 18, 2010, 02:05:32 pm »

Well, I'm doing it to perform some tests, and it works.
It's just about removing the ampersand "&" (in the generated FDS file) in front of the FIRE mesh line if one wants to look at the evacuation, viceversa remove it from the EVAC mesh line to look at the fire simulation.
The only "unpleasand" thing is that I have to export the FDS file from Pyrosim, modify it, and run the simulation manually from the cmd-line. Nevertheless i guess it is faster than disabling all the command from pyrosim.
Logged