Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: Importing FDS+EVAC files  (Read 5345 times)

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Importing FDS+EVAC files
« on: February 01, 2010, 09:47:56 am »

Hi,
I'm trying to import FDS+EVAC validation files "Case A" from http://www.vtt.fi/proj/fdsevac/fdsevac_validation.jsp, but every time Pyrosim crashes.
With "Case B" an error message is displayed ("Error in file ... For input string: "0.3" ").
All FDS files run with no problem if lounched from outside Pyrosim, so they should be correct written.
Can anyone help me?
Thanks
Michele
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: Importing FDS+EVAC files
« Reply #1 on: February 01, 2010, 10:35:57 am »

I suspect FDS+Evac's input format has changed.  One of the reasons whey PyroSim's support isn't very polished is because Timo's still doing a lot of work on the model.  I tested some of the other input files with similarly dissatisfying results.  When we released, all of those V&V test cases worked, so I'm confident something has been updated.

...research...

On that Case B "0.3" error: It looks like FDS now supports a floating-point format for specifying RGB values.  Previously, it used 3 integers from 0-255, now it looks like you can also specify RGB with 3 floats from 0.0 - 1.0.  While this isn't specifically given in the FDS manual, one of the manual's examples does use the floating point format.  We'll need to get this updated in the next version.
Logged

enronc

  • Member
  • **
  • Posts: 16
    • View Profile
Re: Importing FDS+EVAC files
« Reply #2 on: February 01, 2010, 12:13:19 pm »

I agree wiith Charlie because a lot of input files that I have prepared a lot of time ago do'nt work anymore due to the differences of the new versions of the model.
Logged

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Re: Importing FDS+EVAC files
« Reply #3 on: February 02, 2010, 03:28:18 am »

On the User's guide is indicated both FDS and EVAC version.
Installed FDS version can be easily checked by editing "fds5" on cmd line.
1. How can I check the installed EVAC version?
2. Does Pyrosim refer to the separate installed FDS+EVAC or did it install its "own" FDS+EVAC?
3. Do the default EVAC parameter in Pyrosim correspond to the installed EVAC version or may there have some differences?
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: Importing FDS+EVAC files
« Reply #4 on: February 02, 2010, 09:17:44 am »

FDS+EVAC is compiled into the FDS executable.  When you run fds5.exe, the EVAC part is in there and will be used if needed.  PyroSim includes FDS in the "fds" folder of the main PyroSim install folder.

PyroSim is currently bundled with FDS version 5.4.1.  I believe the corresponding version of FDS+EVAC is 2.1.2, though I don't know of any instruction you can give FDS that would verify this and we don't do separate version tracking since EVAC just gets occasionally rolled in to FDS.  We do support the MEAN, PARA, HIGH, and PARA2 log normal parameters and we don't support STRS namelists - which does seem to confirm that version.

The defaults in PyroSim do correspond to the FDS+EVAC defaults used in the version of FDS that is included.  Since the defaults are rarely listed in the manual, we've had to extract them from the source code where necessary.  The defaults used by PyroSim do not necessarily correspond to the defaults used in subsequent versions of FDS+EVAC.

Obviously our support for FDS+EVAC is a bit rough, but the EVAC code is still rapidly changing.  Once it settles down a bit and gives us a stationary target, the support within PyroSim will improve.

(ed. added "necessarily")
« Last Edit: February 02, 2010, 09:29:35 am by Charlie Thornton »
Logged

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Re: Importing FDS+EVAC files
« Reply #5 on: February 03, 2010, 01:48:08 am »

Yes, I agree that there is a lot of movement in FDS and EVAC development and it is a big deal to stay up to date with all new revisions.
Nevertheless, when reading the various user's guide, it is clear that it is very important to understand which version of FDS and EVAC one is dealing with

I have installed Pyrosim which works with FDS 5.4.1 version. When running an simulation I can see that it uses EVAC version is 2.2.0 (open CHID_evac.out to check the installed EVAC version).
This means that even though Pyrosim is not boundled to latest FDS version (which should be 5.4.3) , it works with the lastest EVAC version.

Note: beside Pyrosim I also have latest FDS version separately installed on my computer, perhaps there is an kind of overlapping of used versions?
Logged

Michele

  • Member
  • **
  • Posts: 22
    • View Profile
Re: Importing FDS+EVAC files
« Reply #6 on: February 03, 2010, 03:16:23 am »

I found new useful stuff on that matter.

There are 2 Users guide manuals on EVAC available on VTT web page.
One is downoladed with name "W119.pdf" from the VTT homepage, the second one can be found at this link
http://www.vtt.fi/proj/fdsevac/fdsevac_documents.jsp
The first link on this page opens a newer manual, which can be recognized by the lack of formatted index table and cross references.
This manual is related to FDS 5.4.1, Evac 2.2.0 versions (as can be seen on chapter 11 Conclusion, and not from the first page).

Therefore Pyrosim should have FDS version 5.4.1 and EVAC 2.2.0
Logged