Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: Compatibility of 2015 pyrosim with 2014 and 2012  (Read 1416 times)

joebeginner

  • New Member
  • *
  • Posts: 3
    • View Profile
Compatibility of 2015 pyrosim with 2014 and 2012
« on: March 09, 2016, 05:42:22 pm »

Hello,

I have some models developed on pyrosim 2014. We are getting a license for pyrosim 2015 (latest). I want to know the compatibility of Pyrosim 2015 with previous versions.

For example: We cannot open pyrosim files created in 2010 version in Pyrosim 2014 due to compatibility issues with obstructions etc. Does the same situation exists with the latest version and 2014.

Thanks

Joe
Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile
Re: Compatibility of 2015 pyrosim with 2014 and 2012
« Reply #1 on: March 10, 2016, 11:34:19 am »

Our intention is that any official release PyroSim should be able to open the PSM files from any previous official release of PyroSim. We now maintain a collection of "legacy" PSM files that we use as part of an testing step prior to each release. I didn't realize that some files created in PyroSim 2010 could not be loaded. Could you share the PyroSim 2010 file or send it to support@thunderheadeng.com?

That being said, there are often a lot of warnings that pop up when loading old files. This is because each version of PyroSim targets a specific version of FDS. For example, using PyroSim 2016 to load an older model that used the OBST:SAWTOOTH feature which went away in more recent versions of FDS would result in a warning that the SAWTOOTH entry was being dropped from various obstructions - though the model should still load.
Logged