Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: Dealing with large file  (Read 2954 times)

xyinnn

  • New Member
  • *
  • Posts: 6
    • View Profile
Dealing with large file
« on: October 13, 2014, 04:07:57 am »

Hi,

I have imported 3D dwg file converted from revit. however, the file is too large (with a lot of objects such as furniture, tables, chairs etc), and navigating of the model is difficult. is there any solutions to deal with handling large file.

Thank you
Logged

Dave McGill

  • Member
  • ***
  • Posts: 134
    • View Profile
    • firemodel.ca
Re: Dealing with large file
« Reply #1 on: October 13, 2014, 05:08:23 am »

Hi,

I suggest you delete as many objects as possible from the Revit file before importing into PyroSim. Once you have imported the file, use the Convert to Blocks tool.

Dave
Logged
Dave McGill
firemodel.ca

xyinnn

  • New Member
  • *
  • Posts: 6
    • View Profile
Re: Dealing with large file
« Reply #2 on: October 13, 2014, 07:47:23 am »

Hi Dave,

Thank you for your reply.
I am using Pathfinder instead. and would love to show the objects in the final 3D simulation.
Is there any other solutions to that?

Thank you!
Logged

Richard O'Konski

  • Thunderhead
  • *****
  • Posts: 28
    • View Profile
Re: Dealing with large file
« Reply #3 on: October 13, 2014, 08:40:01 am »

There are a couple good practices that you can use while building your model to make it easier to work with:

1) Like Dave said, delete any imported geometry that isn't necessary - Revit creates very detailed objects and we don't have a way to control that yet.
2) For anything that's left over, hide as much as you can. Anything that is hidden will still show up in the results. Of course, your results may still be difficult to navigate, but you can always use offline rendering to create smoothly animated movies.
3) Setup viewpoints to quickly move about your model.

There are also a few things you can try to improve performance. Here they are in order of effort involved (least effort at the top):

1) If you have an NVidia or AMD (formerly ATI) graphics card, in Pathfinder, go to "Edit->Preferences..." and make sure that "Use Vertex Buffers" is turned on and "Animate Characters in Hardware" is selected. These are the defaults with these graphics cards, but if you ever ran Safe model it would have turned these options off.
2) Make sure you have the latest video drivers for your graphics card.
3) In Revit, make sure you have the "Detail Level" set to "Coarse" and try re-exporting your model and re-importing into Pathfinder (I personally haven't had much luck with this option, but it's worth a try).
4) From Revit, try exporting to an FBX file and in the export dialog make sure "Use LOD" is selected. You'll then have to convert the FBX file to a DWG file using AutoCAD (NOTE: this is currently the only way to get textures as well - we hope to have direct support for importing FBX files in the near future).
Logged
Richard O'Konski
Thunderhead Engineering

Dave McGill

  • Member
  • ***
  • Posts: 134
    • View Profile
    • firemodel.ca
Re: Dealing with large file
« Reply #4 on: October 14, 2014, 06:01:26 am »

Ooops, sorry I didn't read your question carefully.

Dave
Logged
Dave McGill
firemodel.ca