Thunderhead Engineering Forum

Please login or register.

Login with username, password and session length
Advanced search  

News:

Forum moved to https://forum.thunderheadeng.com

Author Topic: FDS run from Pyrosim on local Windows machine gives different result than...  (Read 4950 times)

jme

  • New Member
  • *
  • Posts: 4
    • View Profile

Greetings.

I work for a building engineering company and we use pyrosim to setup the FDS files for our simulations.

We have setup FDS with multiple core/cpu support and we have run a couple of calculations with no problems. (the building engineer confirmed the results according to our old single core system).

The problems consists of 3D Smoke, Slice file and Plot3D File menuitems not showing up when we're trying to view the simulation through pyrosim/smokeview (we're launching Smokeview from pyrosim). This only happens if we do the calculation on our multicore simulation server (running Linux), if we run the same FDS file through Pyrosim and use the locally installed FDS that is bundled with pyrosim, the menu items appear and we can se the animated 3d smoke etc.

Does Pyrosim supply FDS with special parameters ?
I am starting the calculation like this:

mpirun -np 24 fds <name of fds file>

Our server has 24 cores and mpi and FDS does not show any errors (I have looked for CHID.out files describing problems, none exists).
I have also looked in the fds file myself and Smoke3D is not modifyed and according to the userguide the default value is true.

We have not modified the fds file between running we're testing with the same file on the two different systems mentioned above.


If you need more details about our setup feel free to request them and I will supply the needed information

Best regards
JME
Software Developer.

Logged

Charlie Thornton

  • Thunderhead
  • *****
  • Posts: 851
    • View Profile

Smokeview only shows menu items for results data that it has loaded. If the menu items are missing, the most likely cause is that Smokeview did not find the corresponding results data. First, do I understand your two cases correctly:

1. Run the model in PyroSim -> everything works great.
2. Run the model on a Linux cluster, open PyroSim, open results in Smokeview via PyroSim -> data is missing (i.e. fewer menu items)

Are you attempting to leave the results on the cluster, and letting Smokeview pull the data over the network when it runs? That should work, but if it isn't I'd try to copy the folder containing all the results data (the whole thing) to the machine where you are trying to run Smokeview - to remove the network as a variable.
Logged

jme

  • New Member
  • *
  • Posts: 4
    • View Profile

Hello Charlie
thanks for replying.

You understood the scenario correctly.

I will try your proposal when I get back to the office and I will report the results back here.
Logged

jme

  • New Member
  • *
  • Posts: 4
    • View Profile

Ok. I tested your proposal Charlie.

When I move the files to my local computer the menu items is still not appearing.

Can I manually check if the needed files has been generated? and in that case, what is the names of these files?



Logged

jme

  • New Member
  • *
  • Posts: 4
    • View Profile

Ok. I found the solution.

the Pyrosim version I used to test came with SMV version 5.4.3 Aug 31 2009

So I updated Smokeview to the newest version (5.6.3)  from the official website and now it works perfectly.

Thanks for the help.

best regards

JME
Software Dev.

Logged