Thunderhead Engineering Forum

Public Forum => PyroSim => Topic started by: tricia on August 31, 2015, 02:32:13 am

Title: steady fire
Post by: tricia on August 31, 2015, 02:32:13 am
Hi,

I try to create steady fire which is constantly burning without including any fire spread rate and no extinguishing coefficient as well. However, i realise the fire starts to spread to other area then disappear. Unfortunately, the pyrosim file is too big to be uploaded into the website, thus I had attached some screenshots. For reaction, I had used the default values of polyurethane. The fire occurs at the 2nd storey of a 10 storey building. You can see the red fire vent from the images attached. What could be the cause? Is it because the oxygen is used up even though no extinguishing coefficient is stated? Thanks.
Title: Re: steady fire
Post by: Charlie Thornton on August 31, 2015, 10:34:27 am
If I were to guess, I would agree with you about the fire being under ventilated.

The extinguishing coefficient relates to how water impacts the fire (more in section 14.6.2 of the FDS Users Guide, it's in the "Suppression by Water" section).
Title: Re: steady fire
Post by: tricia on September 01, 2015, 12:48:25 am
Thanks for your reply. I notice the 10,000 kW fire will spread to other areas (Pls see attached video and picture). Is it normal to have this result even if I did not specify any spread rate inside the simulation?
Title: Re: steady fire
Post by: Dave McGill on September 01, 2015, 04:53:21 am
Hi Tricia,

It's hard to diagnose without having the input file. Can you put it on Dropbox?

Dave
Title: Re: steady fire
Post by: tricia on September 01, 2015, 06:56:27 pm
Hi,

As requested:
https://www.dropbox.com/s/4c4shwnmixf6nd7/Canopy600mm.psm?dl=0

Had deleted some storeys away but the rest of the parameters remain unchanged.
Thank You.
Title: Re: steady fire
Post by: Dave McGill on September 02, 2015, 07:44:09 am
Hi Tricia,

I changed your cell size to an even 0.2 m and created 4 meshes. It's running fine for me. The revised file is here.

https://www.dropbox.com/s/y17agojhdcdcjug/Canopy600mm_rev1.psm?dl=0

Dave
Title: Re: steady fire
Post by: peter on September 02, 2015, 08:06:57 pm
Hi dave, do u mind saving the older version of pyrosim? I think my version is 2015.1.013. Thanks
Title: Re: steady fire
Post by: Dave McGill on September 03, 2015, 05:47:35 am
Hi Peter,

I can't save to an earlier version of PyroSim, but I've attached the .fds file, which you can import into PyroSim.

Dave
Title: Re: steady fire
Post by: tricia on September 03, 2015, 08:06:52 pm
Hi Dave,

Thanks for your model. Currently running your model now. Understand that it will be ideal to have even cell size and the simulation will run faster with 4 meshes. Just wondering whether the cell size (0.1929 x 0.1786 x 0.1824) which i am using will affect the result much? is it normal to have pic as shown in the attached file even if no fire spread parameter is specified. Thanks.
Title: Re: steady fire
Post by: Dave McGill on September 04, 2015, 07:21:46 am
Hi Tricia,

The original cell size would work fine. I changed it because the original single mesh had over 3 million cells, and I knew i would have to sub-divide it to get quick results. I find it easier to work with cells that have even, and equal, divisions, so I created cells that were 0.20 m a side.

That is an odd looking image, and does not resemble what I was seeing on your simulation. It looks like an underventilated fire. The simple mixing combustion model works by assuming that where ever fuel and oxygen mix in the stoichiometric ratio, combustion will occur. I think that is what you are looking at. The fire spread parameter refers to radially spreading fires over a burner surface, and is not what you are looking at.

The revised file I sent you has an instantly starting fire of ~ 6 MW, that appears to be coming from a mattress. That is not representative of a typical mattress fire.

Dave
Title: Re: steady fire
Post by: tricia on September 05, 2015, 05:03:48 pm
Hi dave, thanks!

The fire starts instantaneously from the red burner vent but somehow will behave oddly after some time. Couldnt seem to find the reason why, perhaps i will try redrawing the model.